在Linux下使用宝塔面板发布.NetCore3.1程序

备注:站长惨痛体验,不要装Centos8,安装netcore环境时候很正常,dotnet执行的时候怎么都会报错的,无奈只能降到7

1,安装宝塔面板

直接百度即可,很简单

2,安装.NetCore SDK 3.1

宝塔面板中没有集成.NetCore SDK,所以我们只能通过yum在终端手动安装。各个不同Linux发行版的安装方法大同小异,在这个官方页面均有详细介绍,这里我用的是CentOS,所以使用yum安装。

根据官方的说法,在安装DotNetCore环境之前需要注册Microsoft Key以及Product Repository,并且还需要安装一些依赖,这一步每台机器只需要运行一次,具体命令如下

sudo rpm -Uvh https://packages.microsoft.com/config/rhel/7/packages-microsoft-prod.rpm

安装dotnet-sdk-3.1,命令如下

sudo yum install dotnet-sdk-3.1

测试是否安装成功:

// 直接看版本:
dotnet --version

3,本地VS发布.NetCore WebApi项目

在Linux下使用宝塔面板发布.NetCore3.1程序

4,宝塔面板发布.netCore项目,并启动项目

在Linux下使用宝塔面板发布.NetCore3.1程序

5,Nginx设置反代访问

在Linux下使用宝塔面板发布.NetCore3.1程序
在Linux下使用宝塔面板发布.NetCore3.1程序

6,解决关闭Shell之后进程停止的问题

现在还有个问题,就是当我们关闭xShell等ssh工具的时候服务进程也会停止运行,我们可使用 Supervisor 守护进程运行。

  1. 在宝塔面板上安装Supervisor
  2. 添加守护进程
在Linux下使用宝塔面板发布.NetCore3.1程序
在Linux下使用宝塔面板发布.NetCore3.1程序
在Linux下使用宝塔面板发布.NetCore3.1程序

7、网站运行

在Linux下使用宝塔面板发布.NetCore3.1程序

网站接口地址:api.01zhp.com 基于netcore 3.1

原创文章,作者:我是读书人,如若转载,请注明出处:https://www.01zhp.com/169.html

发表评论

邮箱地址不会被公开。

评论列表(2条)

  • 花无缺
    花无缺 2021年1月6日 13:26

    百度那么多资料,这个算是比较全的了,开头到结尾